Hallo Uwe,
Danke für die Versions-Informationen und die genaue Fehlermeldung.
Ich vermute, du meinst das Speichern von Änderungen beim Daten-Editieren im Frontend.
Zu: Duplicate entry '279870-2488' for key 'sis_finder_taxonomy_map.PRIMARY'
Visforms speichert erfolgreich die geänderten Daten und wartet auf die Bestätigung.
Anstelle der Bestätigung erhält Visforms eine Fehlermeldung und der Prozess kann nicht ordentlich abgeschlossen werden.
Die Bearbeiten-Ansicht der Formular-Daten verharrt wie beschrieben.
Ursache:
Die in der Fehler-Meldung genannte Tabelle 'finder_taxonomy_map' gehört standardmäßig zu Joomla.
Es handelt sich dabei um einen zentralen Bestandteil der integrierten 'Smart Search' Suchfunktion (Komponente com_finder) von Joomla.
Joomla nutzt diese Tabelle, um die Struktur der Suchfilter abzubilden.
Wenn 'Smart Search' die Website indexiert, zerlegt sie Inhalte in Schlagwörter (Terms) und Kategorien (Taxonomies).
Fragen:
F1 - Nutzt du das Visforms Finder-Plugin?
F2 - Falls ja (F1), tritt der Fehler auch auf, wenn du das Visforms Finder-Plugin deaktivierst?
F3 - Falls nein (F2), kannst du ein Akeeba-Backup der Webseite zum Debuggen zur Verfügung stellen?
Zu F3: Dann müssen wir den Visforms Code debuggen.
Ein administrativer Zugang zum Backend genügt in diesem Fall nicht.
Die Frage ist, ob du uns ein Akeeba-Backup der Webseite zum Debuggen zur Verfügung stellen könntest.
Wir nutzen dazu die folgende Plattform:
wetransfer.com/
Verwende die E-Mail-Adresse des Forums als Empfänger: forum (--at--) vi-solutions.de.
Zusammen mit einer genauen Beschreibung zur Reproduktion des Fehlers, den involvierten Feldern sowie welches Formular und wie es aufgerufen wird.
Optionaler nächster Schritt:
Da es sich um eine reine Index-Tabelle für die Suche handelt, lässt sich das Problem in der Regel sehr einfach und ohne Datenverlust im Joomla-Backend beheben:
S1 - Navigiere zu Komponenten >> Suchindex (oder Smart Search).
S2 - Klicke oben in der Menüleiste auf den Button Löschen (dadurch wird der gesamte alte, potenziell korrupte Suchindex geleert).
S3 - Klicke anschließend auf Indexieren, um den Suchindex komplett neu und sauber aufzubauen.
F4 - Tritt der Fehler erneut direkt beim Aufrufen der Indexierung (S3) im Joomla-Backend auf?
F5 - Falls nein (F4), tritt der Fehler erneut beim Speichern mit Visforms auf?
Liebe Grüße Ingmar