Joomla 5 Notice

Today, October 31, 2023, we released Visforms 4.4.0.
We are pleased to announce that our Joomla extension Visforms is now compatible with Joomla 5.

Our Joomla extension Spambotcheck is currently not yet compatible with Joomla 5 and the installation cannot be started on Joomla 5. We expect to release a release with Joomla 5 compatibility shortly.

For all who are still updateing from Joomla 3 to Joomla 4: Joomla 4 Migration instructions are available here:

There is now a separate Documentation for Visforms for Joomla 4!

Heads Up: This is the documentation for Joomla 3

We recommend using the Documentation for Joomla 4!

It is more up-to-date and extensive. Most of it applies retrospectively to Joomla 3.

Migrate Visforms from Joomla! 2.5 to Joomla! 3

This article explains how to migrate an existing installation of Visforms from Joomla! 2.5 to Joomla! 3.

Important
Visforms does support only versions of Joomla! 3.2 and higher. It is not tested with Joomla! 3.1! Trying to migrate to Joomla! 3.1 by the following steps will fail!

The migration of Visforms from Joomla! 2.5 to Joomla! 3 is userfriendly and easy

Joomla! itself is design to run the update from 2.5 to 3 from the backend using the Joomla Updater. The update of Visforms blends into this concept. You do not need to uninstall but can just migrate by running an upgrade of Visforms after the Upgrade of your Joomla! installation.

We assume that you have made a full backup of your Jooma! installation before you start migrating to Joomla! 3. The migration of Visforms is well tested, but as every Joomla! installation is an idividual combination of extensions and configuration it might well be possible, that you run into problems during the migration process.

  • Go to menu "Extensions" in the backend of your Joomla! installation.
  • Choose submenu "Manage" and find the entry of component Visforms in the extensions list. Determine the version of Visforms you use. If it's lower than 2.0.0 go to the download menu on our website and download the newest Visforms 2.x version. Install this version (without uninstallaling the previous one!) via Extensions Manager.
  • Update your Webseite from Joomla! 2.5.x to the newest Joomla! 3 version (mininmum 3.2.x). For help look at joomla.org.
  • Return on the installation which is now updated to Joomla! 3 menu "Extensions". Go to submenu "Update". There will be an Update for Visforms in the list. Choose it and click the "Update"-Button.
  • Done

Article list