Joomla! 4 Notice

We are happy to announce that as of today - February, 25th, 2022 - all our major Joomla extensions Spambotcheck, Visforms and Visforms Subscription are also available for Joomla 4 To be available. This completes the migration of our software products for Joomla 4.

Migration instructions are available here:

There is now a separate Documentation for Visforms for Joomla 4!

Forum

Visforms subscription user can ask questions in our forum. Please log in with the relevant user first.
Everybody can access the forum for reading.

Inportant forum rule: Please only ask 1 question per topic.

Gleiches Formular zwei Mal auf Startseite

More
2 years 6 months ago #7278 by Administrator AV
Replied by Administrator AV on topic Gleiches Formular zwei Mal auf Startseite
Hallo Thorsten,
ich war auf der Seite und habe da erst mal gar kein Formular gesehen.
Und lange rum suche ich in so einem Fall dann doch nicht.
Daher meine dezidierte Nachfrage.

Du hast mir ehrlich gesagt immer noch nicht genau geschrieben, wo ich hin klicken muss um zu sehen, was du meinst.
Du referenzierst zwar das Kontaktformular (das funktioniert) aber du benennst immer noch nicht das Formular das nicht funktioniert und wie ich da genau hin komme, auch wenn ich es mittlerweile gefunden haben (Online Terminanfrage).

Auf deiner Startseite ist ein Javascriptfehler.
Offensichtlich wird da das visfsorms javascript nicht geladen.
Das liegt vielleicht an der Art und Weise, wie du das Formular eingebunden hast (durch Verwendung einer 3rd Party Erweiterung, die verhindert, dass der Visforms Code richtig abläuft und das Javascript wie gewünscht lädt.)

Gruß,
Aicha
 

:idea: I recommend you the new and up-to-date documentation for Joomla 4:
docs.joomla-4.visforms.vi-solutions.de/en/docs/
Most of this also applies retrospectively to Joomla 3.
Please only ask 1 question per topic :-).

:idea: Ich empfehle Dir die neue und aktuelle Dokumentation für Joomla 4:
docs.joomla-4.visforms.vi-solutions.de/docs/
Das meiste gilt rückwirkend auch für Joomla 3.
Bitte immer nur 1 Frage pro Thema stellen :-).

More
1 week 6 days ago - 1 week 6 days ago #9715 by schulzdesign
Replied by schulzdesign on topic Gleiches Formular zwei Mal auf Startseite
Hallo, liebe Vi-Solutioner :-)

Ich muss dieses Thema leider noch einmal aufmachen, da ich dieses Problem nun bei einer Joomla 4 Website habe und den Fehler einfach nicht finden kann und Hilfe benötige.

Auf folgender Website: [url] de-dsb.de [/url] befinden sich zwei gleiche Formulare, die aber genau betrachtet zwei einzelne Formulare sind. Einmal im Footer und einmal in der Mitte der Seite unter dem Link "Jetzt handeln: ihr schneller Kontakt zur de-dsb GmbH (zum Öffnen klicken)". Das VisForrms-Modul ist von einer anderen Erweiterung "Tabs & Accordions" von Regular Labs umschlossen und öffnet sich erst durch Klicken.

Das hatte ich mit Joomla 3 schon einige Male gemacht.

Jetzt habe ich das Problem, dass das Formular in der Mitte den Absenden-Button nicht aktiviert.
Ich habe das Modul auch schon direkt in das Template eingebunden – ohne die Erweiterung von Regular Labs. Das half leider nicht.

Beide Formular-Module sind mit einem Schattenmenü-Eintrag verknüpft:
de-dsb.de/kontaktformular
[url] de-dsb.de/kontaktformular-footer [/url]
Dort funktionieren beide Formulare.

Hat jemand eine Idee, woran das liegen könnte?

Ich bin wie immer für jede Hilfe dankbar.

Herzliche Grüße
Thorsten
Werbeagentur Schulz-Design e. K.
Last edit: 1 week 6 days ago by schulzdesign.

More
1 week 6 days ago #9716 by Administrator AV
Replied by Administrator AV on topic Gleiches Formular zwei Mal auf Startseite
Hallo Thorsten,

da es sich technisch um 2 unterschiedliche Formulare handelt, gibt es an dieser Stelle von Visforms aus keine Problem.

Wenn ich mir die Seite mit dem Debugger der Browser Entwicklertools ansehen, fällt auf, dass mitten in der Seite etwas sehr seltsam aussieht.
Code:
<div class="bd-layoutcolumn-70 animated bd-animation-11 bd-column"  data-animation-name="fadeIn" data-animation-event="scroll" data-animation-duration="1000ms" data-animation-delay="200ms" data-animation-infinited="false"><div class="bd-vertical-align-wrapper"><img class="bd-imagelink-18 bd-imagescaling bd-imagescaling-13 bd-own-margins bd-imagestyles   "  src="https://de-dsb.de/templates/dedsb/images/designer/941631_bd_media_id_d6de6353d6cc7708fe8220b67093a7a4.png"  alt=""Die Beratungen von de-dsb sind in der Regel förderfähig, unterstützen die IT-Sicherheitsoptimierung.">

Da ist irgendwie der Text 'Die Beratungen von de-dsb sind in der Regel förderfähig, unterstützen die IT-Sicherheitsoptimierung."' inkl. eines einzelnen schließenden " mit in das HTML div Element gerutscht.
" müssen aber immer im Paar vorkommen.
Das einzelne " wirkt wie ein öffnendes " und erzeugt sehr invaliden HTML Code, der letztlich dazu führen kann, das an einer ganz anderen Stelle, das Javascript kaputt gemacht wird.
Im Debugger sieht man, dass der Fehler, der in dieser Div entsteht, letztlich in das Visforms Javascript rein geschoben wird.

Ich denke also, du musst den oben genannten Fehler in dieser animated Div reparieren und dann funktionieren auch beide Formulare wieder.

Herzliche Grüße,
Aicha

:idea: I recommend you the new and up-to-date documentation for Joomla 4:
docs.joomla-4.visforms.vi-solutions.de/en/docs/
Most of this also applies retrospectively to Joomla 3.
Please only ask 1 question per topic :-).

:idea: Ich empfehle Dir die neue und aktuelle Dokumentation für Joomla 4:
docs.joomla-4.visforms.vi-solutions.de/docs/
Das meiste gilt rückwirkend auch für Joomla 3.
Bitte immer nur 1 Frage pro Thema stellen :-).
The following user(s) said Thank You: schulzdesign

More
1 week 6 days ago #9717 by schulzdesign
Replied by schulzdesign on topic Gleiches Formular zwei Mal auf Startseite
Liebe Aicha,

herzlichen Dank für deine Hilfe.

Ich habe anhand deines Codeschnipsels herausgefunden, dass ein Alt-Tag mit einem Anführungszeichen am Anfang eingefügt wurde.
Dieser wurde entfernt und ich habe auch alle weiteren Images auf der Startseite kontrolliert.

Leider führte die Korrektur nicht zu dem gewünschten Erfolg. Der Absenden-Button bleibt inaktiv.

Vorsorglich hatte ich den gesamten Bereich mit dem fehlerhaften Code aus dem Template entfernt, aber auch das half nicht.
Ich bin ratlos.

Herzliche Grüße
Thorsten
Werbeagentur Schulz-Design e. K.

More
1 week 5 days ago #9718 by Administrator AV
Replied by Administrator AV on topic Gleiches Formular zwei Mal auf Startseite
Lieber Thorsten,
dann ist auf jeden Fall schon mal ein Fehler weniger auf der Seite.
Du schreibst, wenn du das Formular über das Schattenmenü aufrufst, funktioniert es.
Funktioniert das Formular denn, wenn du es direkt als Visforms Module in die Seite einfügst?
So wie das andere Formular unten im Footer, das funktioniert?
Liebe Grüße,
Aicha

:idea: I recommend you the new and up-to-date documentation for Joomla 4:
docs.joomla-4.visforms.vi-solutions.de/en/docs/
Most of this also applies retrospectively to Joomla 3.
Please only ask 1 question per topic :-).

:idea: Ich empfehle Dir die neue und aktuelle Dokumentation für Joomla 4:
docs.joomla-4.visforms.vi-solutions.de/docs/
Das meiste gilt rückwirkend auch für Joomla 3.
Bitte immer nur 1 Frage pro Thema stellen :-).
The following user(s) said Thank You: schulzdesign

More
1 week 5 days ago #9719 by schulzdesign
Replied by schulzdesign on topic Gleiches Formular zwei Mal auf Startseite
Liebe Aicha,

herzlichen Dank für deine rasche Antwort.

Ich hatte das Modul vor dem Posten direkt eingebunden und getestet. Da funktionierte es nicht. Jetzt hatte ich es erneut direkt eingebunden und es funktioniert. Ich vermute, dass es mit der Erweiterung von Regular Labs zu tun hat und habe das Problem in das dortige Forum verlagert.

Nochmals herzlichen Dank und bis zum nächsten Mal :-)

Liebe Grüße aus Hannover.

Herzliche Grüße
Thorsten
Werbeagentur Schulz-Design e. K.

Moderators: Administrator AVAdministrator IV
Powered by Kunena Forum