Joomla 6 Notice

We are pleased to announce that all our Joomla extensions have been compatible with Joomla 6 since October 14th, 2025.

For those currently upgrading from Joomla 3 to 4: Instructions for Joomla 4 migration can be found here:

There are standalone documentations Visforms Joomla 4, Visforms Joomla 5 and Visforms Joomla 6.

Forum

Visforms Subscription user can ask questions in our forum. Please log in with the relevant user first.
Everybody can access the forum for reading.

Please only ask 1 question per topic.

Important information for almost every question:
V1: Which Visforms version is running?
V2: Which Joomla version is running?
V3: Which PHP version is running?

Speichern von bestehenden Formularen

  • eduard.gradl@reg-mfr.bayern.de
  • Topic Author
  • Offline
More
5 days 5 hours ago #12601 by eduard.gradl@reg-mfr.bayern.de
Speichern von bestehenden Formularen was created by eduard.gradl@reg-mfr.bayern.de
Hallo,
unsere Visforms Subscription -Version läuft mit folgenden Versionen
V1: Welche Visforms-Version läuft?  5.6.4
V2: Welche Joomla-Version läuft? 5.4.9
V3: Welche PHP-Version läuft? 8.3.6
Datenbank: mysql (pod): 8.4.11

Folgendes Problem tritt auf:
Einzelne Formulare in der bestehenden  Installation werden geöffnet. Der Speicher-Button löst zwar den Speicherprozess aus, eine Speicherung der Änderungen erfolgt, das Formularfenster schließt nicht und der Speicherprozess wird nicht komplett durch Schließen des Fensters beendet.

Folgende Fehlermeldung wird nach ca. 1. Minute zurückgegeben:
Speichern fehlgeschlagen. Fehler: Duplicate entry '279870-2488' for key 'sis_finder_taxonomy_map.PRIMARY'

Die Installation und visforms-Formulare wurden unter joomla 5 neu angelegt. Es lässt sich keine Systematik erkennen in welchem Formular der Fehler auftritt (z.B. nach  Erstellungszeitraum, ... ).
Für das Frontend sind einige CSS-Einstellungen im template hinterlegt, die jedoch nur das Design des templates betreffen und keinen Einfluss auf visforms haben solten.

Vielen Dank für Ihre Unterstützung.
Uwe Geuder
 

More
4 days 6 hours ago - 4 days 6 hours ago #12602 by Administrator IV
Replied by Administrator IV on topic Speichern von bestehenden Formularen
Hallo Uwe,

Danke für die Versions-Informationen und die genaue Fehlermeldung.
Ich vermute, du meinst das Speichern von Änderungen beim Daten-Editieren im Frontend.

Zu: Duplicate entry '279870-2488' for key 'sis_finder_taxonomy_map.PRIMARY'

Visforms speichert erfolgreich die geänderten Daten und wartet auf die Bestätigung.
Anstelle der Bestätigung erhält Visforms eine Fehlermeldung und der Prozess kann nicht ordentlich abgeschlossen werden.
Die Bearbeiten-Ansicht der Formular-Daten verharrt wie beschrieben.

Ursache:

Die in der Fehler-Meldung genannte Tabelle 'finder_taxonomy_map' gehört standardmäßig zu Joomla.
Es handelt sich dabei um einen zentralen Bestandteil der integrierten 'Smart Search' Suchfunktion (Komponente com_finder) von Joomla.
Joomla nutzt diese Tabelle, um die Struktur der Suchfilter abzubilden.
Wenn 'Smart Search' die Website indexiert, zerlegt sie Inhalte in Schlagwörter (Terms) und Kategorien (Taxonomies).

Fragen:

F1 - Nutzt du das Visforms Finder-Plugin?
F2 - Falls ja (F1), tritt der Fehler auch auf, wenn du das Visforms Finder-Plugin deaktivierst?
F3 - Falls nein (F2), kannst du ein Akeeba-Backup der Webseite zum Debuggen zur Verfügung stellen?

Zu F3: Dann müssen wir den Visforms Code debuggen.

Ein administrativer Zugang zum Backend genügt in diesem Fall nicht.
Die Frage ist, ob du uns ein Akeeba-Backup der Webseite zum Debuggen zur Verfügung stellen könntest.
Wir nutzen dazu die folgende Plattform: wetransfer.com/
Verwende die E-Mail-Adresse des Forums als Empfänger: forum (--at--) vi-solutions.de.
Zusammen mit einer genauen Beschreibung zur Reproduktion des Fehlers, den involvierten Feldern sowie welches Formular und wie es aufgerufen wird.

Optionaler nächster Schritt:

Da es sich um eine reine Index-Tabelle für die Suche handelt, lässt sich das Problem in der Regel sehr einfach und ohne Datenverlust im Joomla-Backend beheben:
S1 - Navigiere zu Komponenten >> Suchindex (oder Smart Search).
S2 - Klicke oben in der Menüleiste auf den Button Löschen (dadurch wird der gesamte alte, potenziell korrupte Suchindex geleert).
S3 - Klicke anschließend auf Indexieren, um den Suchindex komplett neu und sauber aufzubauen.

F4 - Tritt der Fehler erneut direkt beim Aufrufen der Indexierung (S3) im Joomla-Backend auf?
F5 - Falls nein (F4), tritt der Fehler erneut beim Speichern mit Visforms auf?

Liebe Grüße Ingmar

:idea: I recommend you the new and up-to-date documentation for Joomla 6:
docs.joomla-6.visforms.vi-solutions.de/en/docs/
Please ask only 1 question per topic :-).

:idea: Ich empfehle Dir die neue und aktuelle Dokumentation für Joomla 6:
docs.joomla-6.visforms.vi-solutions.de/docs/
Bitte immer nur 1 Frage pro Thema stellen :-).
Last edit: 4 days 6 hours ago by Administrator IV.

Moderators: Administrator AV, Administrator IV
Powered by Kunena Forum